menu search
brightness_auto
more_vert

I got the notification of an update for WordFence , I updated without worrying much. Moments after the update I got an email that my website is down. I opened my site and was greeted by : HTTP ERROR 500. Need Help

My Website Error Log :

PHP Fatal error: require_once(): Failed opening required 'lib/wordfenceClass.php' (include_path='.:/opt/alt/php71/usr/share/pear') in /home/x/public_html/xx/wp-content/plugins/wordfence/wordfence.php on line 72

What do I do ?

thumb_up_off_alt 0 like thumb_down_off_alt 0 dislike

1 Answer

more_vert

Hello , 

You are not alone - Wordfence 7.2.4 update breaks wordpress as there is reference of lib/wordfenceClass.php in wordfence.php

    require_once('lib/wordfenceClass.php');

while there is no wordfenceClass.php in lib folder.

I will let you know a temporary fix for this and that is to disable Wordfence until an update is pushed by the authors, as other users are also facing the same issue

[FIX] WordFence Update Breaks Wordpress 

Open FTP or any File Manager you have (cpanel etc) and go to your Wordpress directory and navigate to wp-content/plugins/ inside the plugins folder you will see a folder "wordfence" rename that folder to anything "wordfence_" and your site will start working.
Reinstalling the Plugin as the support suggests mostly would not work in this case as the authors would need to bring an update to the plugin and fix the issue.
Hope this helps !!!
thumb_up_off_alt 0 like thumb_down_off_alt 0 dislike
Welcome to Ask Techie
Ask questions and receive answers from other members of the community. Hacking, Technology, Gaming, Programming, Blockchain and everything to get you going with your Cyber World.

222 questions

227 answers

401 comments

726,915 users

...